Search found 26 matches

by IllinoisMike
Wed Sep 17, 2014 11:45 am
Forum: Engine, Driveline, Suspension & Steering
Topic: exhaust / intake maniforld
Replies: 4
Views: 1763

exhaust / intake maniforld

It appears my existing exhaust and intake manifolds on my 1950 std 8. (288) are in such poor condition that it is recommended I replace them Only price I got was $525 for exhaust and $385 for intake. Anyone have these items for sale at a better price or a source other than the "Big 2 suppliers"? tha...
by IllinoisMike
Tue Aug 26, 2014 7:57 am
Forum: Electrical & Fuel
Topic: Instrument Lights 1950
Replies: 4
Views: 1390

Instrument Lights 1950

Most of my lights are working. The push-switch for the instrumheent lights DOES illuminate the lights across the top of the switches when the headlights are on, but the instrument panel with gauges, speedo etc does not light up. Is there some dimmer control that might have these instrument lights tu...
by IllinoisMike
Wed Aug 13, 2014 2:41 pm
Forum: Engine, Driveline, Suspension & Steering
Topic: clicking valves
Replies: 7
Views: 2338

Re: clicking valves

I will report on the progress over the weekend
thanks to all for input
by IllinoisMike
Wed Aug 13, 2014 10:17 am
Forum: Engine, Driveline, Suspension & Steering
Topic: clicking valves
Replies: 7
Views: 2338

Re: clicking valves

Has anyone had success at removing valve springs WITHOUT removing the head? If so, what is the recommended procedure?
by IllinoisMike
Mon Aug 11, 2014 8:57 am
Forum: Engine, Driveline, Suspension & Steering
Topic: clicking valves
Replies: 7
Views: 2338

Re: clicking valves

The majority opinion it is a weak valve spring and if it were not, per previous post, it would be impossible or nearly so to rotate the spring and valve regardless of the position of the lifter. My position at this point is to replace the spring. Replacing lifter would require major work. Has anyone...
by IllinoisMike
Sat Aug 09, 2014 2:53 pm
Forum: Engine, Driveline, Suspension & Steering
Topic: clicking valves
Replies: 7
Views: 2338

clicking valves

I have a recurring intermittent clicking when the engine is running. Removing the valve covers seems to indicate the noise comes from the #3 intake valve The valve spring does not appear broken but when the spring is down the valve will still spin. A temp shim seemed to remove clicking. The suggesti...
by IllinoisMike
Tue Jul 29, 2014 9:24 am
Forum: Engine, Driveline, Suspension & Steering
Topic: temperature sending unit resistance
Replies: 2
Views: 948

temperature sending unit resistance

After some lengthy battle with carburetorand timing, my 1950 (288 cu in) runs fairly well. I have been getting the temperature guage to run about half-way between middle and hot after some driving. I did a pretty good job of flushing the engine and did the white vinegar and water routine. Still regi...
by IllinoisMike
Thu Jun 05, 2014 10:12 am
Forum: Engine, Driveline, Suspension & Steering
Topic: Rough running /stalling
Replies: 1
Views: 818

Rough running /stalling

I am having trouble getting my 1950 to run without coughing and sputtering. The following actions have been done: 1. Gas tank removed and refurbished 2.. Gas lines blown out 3. Auxilliary electric fuel pump added 4. Carburetor rebuilt = accel valve, etc work fine 5. Elec and Mech fuel pump appear to...
by IllinoisMike
Tue Mar 11, 2014 12:54 pm
Forum: Electrical & Fuel
Topic: 1950 lights etc
Replies: 3
Views: 1178

Re: 1950 lights etc

Thanks a whole bunch for the detailed answer. The photo that was on the first post did not look like the switches. the photo looked as if they were knob type rather than push type. Sorry for not properly interpreting. I am off tomorrow morning with your reply printed and an enlargement of the wiring...
by IllinoisMike
Tue Mar 11, 2014 8:45 am
Forum: Electrical & Fuel
Topic: 1950 lights etc
Replies: 3
Views: 1178

1950 lights etc

My recently acquired 1950 had some electrical working. The turn signals worked but the license plate light was flashing as well. The horn worked and the headlight pilot light worked. Now, none of this works. the brake lights still work and the gas gauge, and ammeter gauge work. I get nothing from th...